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ArcGIS Pro:ディゾルブ、ユニオン、インターセクト等を行うとフィーチャの形状が変わったり、空の出力が生成される

ナレッジ番号:3487 | 登録日:2023/05/29 | 更新日:2023/08/16

説明

[ディゾルブ] ツールや [インターセクト] ツール等を実行後、フィーチャの形状が元のフィーチャと異なったり、空の出力が生成されてしまうことがあります。

原因

ディゾルブ等のデータの処理を行う場合、座標精度という概念が適用され、座標系によってデータの精度が決定されます。
座標系の定義がない場合でもこの座標精度が考慮され、処理結果が元のフィーチャの形状と異なったり、空の出力が生成されることがあります。

あるいは、データ (ジオメトリ) が破損している場合も、フィーチャの形状が変更されたり、フィーチャ自体が消滅したりすることがあります。

対処方法1

空の出力が生成されたり、フィーチャの形状が異なったりする原因として、データに投影法の定義がされていない、もしくはデータそれぞれに異なる座標系が定義されていることがあります。

ディゾルブ等を行うデータに投影法の定義がされていない場合は、[投影法の定義] ツールで座標系の定義します。
[投影法の定義] ツールについては「ArcGIS Pro: データに投影法(座標系)を定義する方法(投影法の定義)」 をご確認ください。

異なる座標系が定義されている場合は、 [投影変換] ツールで座標系を揃えます。
[投影変換] ツールについては「ArcGIS Pro: フィーチャクラス、シェープファイルの測地基準系や座標系を変更するには? (投影変換)」 をご確認ください。

対処方法2

データが破損しているため、ディゾルブ等の処理によりフィーチャが消滅することがあります。

データのジオメトリに問題があると考えられる場合は、データに対して [ジオメトリのチェック] ツールを実行します。
[ジオメトリのチェック] ツールを実行し、問題が発見されると出力されたテーブルにフィールドにフィーチャの ID と問題の内容が記載されます。

問題が発見された場合は、続けて [ジオメトリの修正] ツールを実行します 。
※[ジオメトリの修正] ツールを実行することで、本来なら存在できないような微小ポリゴンが消滅することがあります 。

[ジオメトリのチェック] ツールおよび [ジオメトリの修正] ツールの詳細については「ArcGIS Pro: データに問題がないかどうかをチェックし、修復したい (ジオメトリの修正)」をご確認ください。
※ [ジオメトリの修正] ツールは、データを上書きしますので、[ジオメトリの修正] ツールの実行前には、必ずデータのバックアップをご用意ください。

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