FAQ
ArcGIS Pro から ArcGIS Enterprise にサイン インを試みると「不明なエラーが発生しました。ライセンス マネージャーが有効なライセンスで実行されていることを確認するように管理者に連絡してください。」のメッセージが表示される
ナレッジ番号:5927 | 登録日:2025/05/12 | 更新日:2025/05/13
概要
ArcGIS Pro から ArcGIS Enterprise へサイン インを試みると「不明なエラーが発生しました。ライセンス マネージャーが有効なライセンスで実行されていることを確認するように管理者に連絡してください。」のメッセージが表示されることがあります。
原因
ArcGIS Enterpirse バージョン 11.4 以降の場合、Portal for ArcGIS へインポートしたライセンス ファイルの [ArcGIS Enterprise ポータルのパブリック URL] が正しく指定できていない場合に表示されることが多いです。
本 FAQ ではこの場合の対処を中心に記載します。対処
対処として、My Esri で Portal for ArcGIS 指定ユーザー ライセンスのライセンス ファイルの指定内容を確認の上で、ライセンス ファイルを再作成します。
- My Esri でのライセンス ファイルの指定内容を確認します。
- My Esri → [ライセンス] → [ライセンス ファイル] → [ArcGIS および ArcGIS Pro のポータル] → 該当のライセンス ファイルのアクション列にある [ライセンス ファイルの編集(アイコン:鉛筆)] をクリックします。「ライセンス ファイルの編集の確認」ウィンドウが表示されるため、[了解] をクリックします。
- [ユーザー タイプとアプリケーション ライセンスの選択] 画面が表示されますので、[ライセンス管理] 画面が表示されるまで [次へ] をクリックします。
※[エンド ユーザー情報] 画面が表示された場合は [前へ] をクリックして、[製品とライセンス オプションの選択] 画面まで戻ります。 - [ライセンス管理] 画面上にある [ArcGIS Enterprise ポータルのパブリック URL] が、下記「設定例」のように設定されているか確認します。
■設定例:
「ホスト」/「コンテキスト」
・「ホスト」は、組織の完全修飾ドメイン名 (FQDN)、 またはドメイン名システム (DNS) エイリアスを表します。多くの場合、Portal for ArcGIS を構築するマシンの FQDN(ホスト名+ドメイン名)を指定します。
・「コンテキスト」は、Portal for ArcGIS 用の Web Adaptor 名です。Portal for ArcGIS 用の Web Adaptor 名は「ArcGIS Enterprise 基本構成セットアップガイド」の「3.3. ArcGIS Web Adaptor のインストールおよび構成」の手順 6 (pp.21-22)で設定した名前です。
- 設定例のように指定されていない場合、続けて手順 2-1 に進みます。
- My Esri でライセンス ファイルの編集を続行します。
- [ArcGIS Enterprise ポータルのパブリック URL] を変更して [次へ] をクリックします。
- [エンド ユーザー情報] 画面にて内容を確認の上で、[次へ] をクリックします。
- [ライセンス ファイルの確認] 画面にて、[ファイルの作成] をクリックします。
「ポータル ライセンス リクエストが正常に完了しました。」というメッセージが表示されます。
- Portal for ArcGIS ポータルサイトの [ライセンス] タブにてライセンス ファイルをインポートします。
- My Esri でのライセンス ファイルの指定内容を確認します。
関連する質問
-
ArcGIS Enterprise:ArcGIS Enterprise でアクセスするサイトの URL・用途・使用するアカウント
-
ArcGIS Pro:Portal for ArcGIS 指定ユーザー ライセンスのセットアップ (ポータル サイトを利用する・しているユーザー向け)
-
ArcGIS Pro:Portal for ArcGIS 指定ユーザー ライセンスのセットアップ (ポータル サイトを利用しないユーザー向け)
メタデータ
機能
製品
バージョン
外部URL