FAQ
縮尺を変更するとフィーチャが表示されなくなる

ナレッジ番号:1584 | 登録日:2023/05/29 | 更新日:2024/01/22

現象

ある縮尺では表示されているフィーチャが、拡大、または縮小して縮尺を変えると消えてしまう、または、表示されません。
レイヤーーに対して縮尺範囲の設定は行っていません。

原因

  1. 空間インデックスが破損していることが考えられます。
  2. データは破損していることが考えられます。

回避策

空間インデックスの削除および再作成

空間インデックスを削除します。 必要な場合は、再度、空間インデックスを作成します。空間インデックスの再作成が必要でしたら、空間インデックスの削除後、ご作成ください。

空間インデックスの削除の手順

  1. [カタログ] ウィンドウで縮尺表示に問題のあるレイヤーを右クリックします。
  2. [プロパティ] をクリックします。
  3. [インデックス] タブ をクリックします。
  4. [空間インデックス] の部分で[削除]をクリックします。
    空間インデックスが作成されていない場合は、削除ボタンがグレーアウトしています。

空間インデックスの作成の手順

  1. [カタログ] ウィンドウでレイヤーを右クリックします。
  2. [プロパティ] をクリックします。
  3. [インデックス] タブ をクリックします。
  4. [空間インデックス] の部分で [追加] をクリックします。
空間インデックスの削除や作成は、ArcToolbox → [データ管理ツール] → [インデックス] → [空間インデックスの削除] や[空間インデックスの追加]ツールでできます。

ジオメトリのチェックおよび修正

ジオメトリのチェックツールを使用してデータの破損がないかを確認します。

ArcToolbox → [データ管理ツール] → [フィーチャ] → [ジオメトリのチェック] ツールを実行します。
ジオメトリに問題がある場合は、出力されたテーブルに問題の見つかったフィーチャのID等が記載されます。
ただし、ArcGIS以外で作成されたデータに含まれる問題やご利用の場合や [ジオメトリの修正] ツールで直せない問題はこのツールで発見することができません。)。
[ジオメトリのチェック] ツールを実行後、問題がみつかった場合は、ArcToolbox → [データ管理ツール] → [フィーチャ] → [ジオメトリの修正]ツールを実行します。

[ジオメトリの修正] ツールは、データを上書きしますので、必ずバックアップデータを用意してから、実行してください。

関連する質問

メタデータ

種類

製品

バージョン