FAQ
ArcGIS Pro: 縮尺を変更するとフィーチャが表示されなくなる

ナレッジ番号:1584 | 登録日:2023/05/29 | 更新日:2026/03/16

現象

特定の縮尺では表示されているフィーチャが、拡大または縮小して縮尺を変更すると表示されなくなる/消えることがあります。
なおレイヤーの表示縮尺範囲(最小縮尺/最大縮尺)は設定していません。

原因

以下のような原因が考えられます。

  • 空間インデックスが破損している
  • データ自体が破損している

回避策

空間インデックスの削除および再作成

空間インデックスが破損している場合、削除して再作成すると改善することがあります。

空間インデックスの削除の手順

  1. [カタログ] ウィンドウで該当のデータを右クリックします。
  2. [プロパティ] をクリックします。
  3. [インデックス] タブをクリックします。
  4. [空間インデックス] セクションを展開し、 [削除] をクリックします。
    空間インデックスが作成されていない場合は、 [削除] ボタンがグレーアウトしています。


空間インデックスの作成の手順

  1. [カタログ] ウィンドウで該当のデータを右クリックします。
  2. [プロパティ] をクリックします。
  3. [インデックス] タブをクリックします。
  4. [空間インデックス] セクションを展開し、 [作成] をクリックします。


ジオプロセシング ツールを使用する場合
ArcGIS Pro のジオプロセシング ツールからも操作可能です。
  • [データ管理ツール] → [インデックス] → [空間インデックスの削除]
  • [データ管理ツール] → [インデックス] → [空間インデックスの追加]

ジオメトリのチェックおよび修正

データが破損している場合、ジオメトリ エラーが原因で表示されないことがあります。


ジオメトリのチェック

  1. [解析] タブの [ツール] をクリックし、 [ジオメトリのチェック] ツールを検索し、起動します。
  2. 以下のパラメーターを入力して実行します。
    ・入力フィーチャ:対象のレイヤー
    ・出力テーブル:検証結果を格納するテーブルの保存先と名称
    ・検証方法:[Esri] と [OGC] のいずれかから選択
  3. ジオメトリに問題がある場合は、出力テーブルに、問題があるフィーチャ ID とエラー内容が記録されます。
  4. ※ ArcGIS 以外のソフトで作成されたデータの場合など、このツールで検出できない問題もあります。

ジオメトリの修正

  1. ジオメトリのチェックで問題が確認された場合、[解析] タブの [ツール] をクリックし、 [ジオメトリの修正] ツールを検索し、起動します。
  2. 以下のパラメーターを入力して実行します。
    ・入力フィーチャ:対象のレイヤー
    ・NULL ジオメトリを含むフィーチャを削除:ジオメトリがないフィーチャを削除する場合はチェック
    ・検証方法:[Esri] と [OGC] のいずれかから選択
[ジオメトリの修正] ツールは、データを上書きします。必ずバックアップを取ってから実行してください。

関連する質問

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