FAQ
問題 : Survey123 Web サイトをアプリとして登録をしている Portal for ArcGIS(10.3.x もしくは 10.4.x) からのアップグレードで、アップグレード後の初期管理者アカウントの生成に失敗する。

ナレッジ番号:5377 | 登録日:2023/07/26 | 更新日:2024/11/21

現象

Survey123 Web サイト(survey123.arcgis.com)をアプリとして登録をしている Portal for ArcGIS(10.3.x もしくは 10.4.x) からのアップグレードで、アップグレード後の初期管理者アカウントの生成に失敗する。

説明

バージョン 10.4.1 以前の Portal for ArcGIS で Survey123 for ArcGIS Web サイトを登録していた場合、そのまま Portal for ArcGIS をアップグレードすると、
アップrグレード時の初期管理者アカウントの作成に失敗します。

参考情報2:Survey123 Web サイト(survey123.arcgis.com)をアプリとして登録する

原因

上記 [説明] 項目の参考情報に従って、Survey123 Web サイトを Esri のアプリとして登録することはできますが、Portal for ArcGIS 10.5.x では規定の Esri のアプリとして認識できないため、アップグレード時に不整合が生じるため。

回避策

アップグレードを行う前に、既存の Portal for ArcGIS からそれぞれのアプリの登録解除を行い、アプリのアイテムを削除します。

  • ArcGIS Portal Directory sharing REST インターフェースにアクセスし、管理者権限を有するアカウントでログインします。
    URL の形式例:https://webadaptorhost.domain.com//sharing/rest
  • Survey123 Web サイトをアプリとして登録したアカウント情報にアクセスします。
    URL の形式例:https://webadaptorhost.domain.com/webadaptorname/sharing/rest/content/users/<ユーザー名>
  • Survey123 Web サイトのアプリを選択します。
  • ページ下部にある [Related Operations] から、[Unregister App] をクリックし、アプリの登録を解除します。
  • 続いて表示されるページ下部にある [Supported Operations] から、[Delete Item] をクリックして、アイテムを削除します。
    このときアプリの情報は削除されますが、アプリで作成・利用したコンテンツは削除されません。
  • 両方のアプリの削除を行った後、アップグレードを行い、再度アプリとして登録すれば、利用可能になります。

関連情報

メタデータ

種類

製品