FAQ
プリンターのIPアドレス変更後、ArcMap からの印刷がプリンターに出力されない

ナレッジ番号:3110 | 登録日:2023/05/29 | 更新日:2024/11/21

現象

ネットワーク プリンターの IP アドレスを変更した後、IP アドレス変更前に作成したマップ ドキュメントからの印刷がプリンターに出力されない。新しく作成したマップ ドキュメントでは問題なくプリンターに出力される。

原因

製品の既知の制限です。

マップ ドキュメントには前回使用したプリンターの情報(プリンター名と IP アドレスの組)が保存されて、ArcMap にて既存のマップ ドキュメントを開き、前回と同じプリンターに向けた印刷操作を行うと、マップ ドキュメント内に保存されているプリンターの IP アドレスへ印刷ジョブが送られます。
この仕様から、プリンターの名前は変わらず IP アドレスのみが変更されたときには、以前に作成されたマップ ドキュメントからの印刷が出力されなくなります。(プリンターの旧 IPアドレスに出力しようとします)

対処方法

次の2通りの対処があります。

  • (ArcGIS のみで対応する方法)マップ ドキュメントを開き、いったん別のプリンターを指定してから元に戻す
    1. ArcMap にてマップ ドキュメントを開き、[ファイル] メニュー → [ページ設定/印刷設定] 画面にていったん別のプリンターを指定して [OK] をクリックします。
    2. 再度 [ファイル] メニュー → [ページ設定/印刷設定] 画面を開き、出力したいプリンターを指定して [OK] をクリックします。
       
  • (コンピューター側の設定変更)プリンターの名前を変更する
     
    ArcMap ではプリンター名でプリンターが識別されるため、コンピューターに登録されているプリンター名を変更すると、ArcMap はマップ ドキュメントに保存されていたプリンターが使用できないと認識して古いプリンター情報を使用しません。
    (手順)
    1. [コントロール パネル] → [デバイスとプリンター] にて該当のプリンターの [プリンターのプロパティ] を開き、[全般] タブでプリンターの名前を変更します。(例えばプリンター名の末尾に「_1」をつける)
    2. ArcMap にてマップ ドキュメントを開くと、[ファイル] メニュー → [ページ設定/印刷設定] 画面には前回使用していたプリンターの代わりに別のプリンター(通常使うプリンターとして設定されているもの)がデフォルトとして表示されているので、必要に応じてプリンターの指定を行います。

関連する質問

メタデータ

種類

製品

バージョン