FAQ
エラー:SQL Server でログに -549 エラーが記録されてジオデータベースのアップグレードが失敗する
ナレッジ番号:2718 | 登録日:2023/05/29 | 更新日:2024/11/21
エラーメッセージ
SQL Server の sde スキーマ ジオデータベースのアップグレード時に、ジオプロセシング ツールで以下のエラーメッセージが返されてアップグレードに失敗します:
サーバのテーブルとストアド プロシージャを更新しています。
サーバのテーブルとストアド プロシージャを更新できませんでした。
詳細はアップグレード ログファイルを参照してください:
C:\Users\sean4788\AppData\Local\Esri\Desktop10.1\GDBUpgrade.log
C:\Users\sean4788\AppData\Local\Temp\2\sde_setup.logUnpaused the database.
(UpgradeGDB)を実行できませんでした。
sde_setup.log には以下のメッセージが表示されます:
[Tue Sep xxxxx]
DB_instance_open() against SQL Server using OLEDB driver.
[Tue Sep xxxxx] ERROR installing/upgrading ArcSDE, Error = -549
Updating server tables and stored procedures.
原因
sde ユーザを SQL Server の sysadmin 固定サーバロールに追加することはサポートされていません。
回避方法
sde スキーマ ジオデータベースをアップグレードする際に使用するログインと権限は、使用しているジオデータベース モデル(シングル データベース モデルまたはマルチ データベース モデル)によって異なります。
アップグレードに必要なユーザの権限の詳細は関連情報のヘルプをご参照ください。
シングル データベース ジオデータベースをアップグレードする場合は、アップグレードの前に sde ユーザを db_owner データベース ロールに追加します。
または、sa など他の sysadmin 権限を持つユーザやデータベースの db_owner ロールに追加されている他のユーザでログインします。
関連するユーザデータベースの有無にかかわらず sde という名前のデータベースを含むマルチ データベース ジオデータベースをアップグレードする場合は、SQL Server インスタンスの sysadmin 権限を持つ sde 以外のユーザでログインします。
関連情報
SQL Server でのジオデータベースに対するユーザ権限備考
プラットフォーム:Windows Server 2003、Windows Server 2008、Windows 7
メタデータ
種類
製品
バージョン