FAQ
借用したライセンスの返却を行うとエラーが表示される
ナレッジ番号:2599 | 登録日:2023/05/29 | 更新日:2024/11/21
現象
ArcGIS Desktop 製品では CU(同時使用)ライセンスにおいてクライアント PC にてライセンスの借用が可能ですが、借用したライセンスをクライアント PC から返却しようとすると以下のようなエラーが表示されてライセンスが返却できないことがあります。
原因
ご使用の環境により様々な要因が想定されますので、以下の回避方法をそれぞれお試しください。
回避方法
方法1
お使いのライセンスマネージャーをインストールされている PC(ホストPC )において、コンピューター名とフルコンピューター名(ドメイン名を含む)が異なる場合
- お使いのライセンスサーバー PC においてコンピューター名とフルコンピューター名を確認します。
Windows 10 の場合には Windows [スタート] を右クリックし、[設定] → [システム] → [詳細情報] をクリックし、コンピューター名とフルコンピューター名を確認し、それぞれの名称をメモ帳などに控えます。 - ライセンス サーバー PC の IP アドレスを確認します。コマンドプロンプト ([スタート] → [ファイル名を指定して実行] をクリックし、cmd と入力し、ENTER キーを押します。) コマンドプロンプトが表示されたら ipconfig と入力します。表示された画面の IPV4 アドレスの値をご確認いただき、メモ帳などに控えます。
- クライアント PC において C:\Windows\system32\drivers\etc フォルダにある hosts ファイルをメモ帳で開きます。
- hosts ファイルに1の手順で取得したコンピューター名、ドメイン名、2 の手順で取得した IP アドレスを記載します。
(例)
IPアドレス:123.45.678.90
ドメイン名:esrijapan.esrij.com
コンピューター名:esrij
の場合には、hosts ファイルには以下のように記述します。123.45.678.90 esrijapan.esrij.com esrij
記入後、hosts ファイルを上書き保存して終了します。
方法2
クライアント PC でライセンスマネージャを IP アドレスで指定している場合
クライアント PC の ArcGIS Administrator を起動し、左側のツリーから [Desktop] をクリックし、右側の [ライセンスマネージャー (同時使用ソフトウェア製品用)] 部分に指定されている名称が以下の画像のように IP アドレスで指定されている場合には、返却ができないことがあります。この場合には IP アドレスではなく、サーバー PC (ホストPC) のコンピューター名を指定してから返却を行ってください。
方法3
システム環境の設定
クライアント PC 側での設定です。- Windows の[スタート] メニュー→ [コントロールパネル] → [システム] → [システムの詳細設定] をクリックします。
- [システムのプロパティ] ダイアログ ボックスの [詳細設定] タブ→ [環境変数] をクリックします。
- [環境変数] ダイアログ ボックスの下の欄の [システム環境変数] で [新規] をクリックします。
- [新しいシステム変数] ダイアログ ボックスにて、変数名に [FLEXLM_TIMEOUT] 、[変数値] に [1000000] と入力します。
すべてのダイアログで[OK]をクリックして閉じます。
※もし、1000000マイクロ秒(1秒)の値でもライセンスを返却出来ない場合は、ライセンスサーバーに返却ができるまで1000000マイクロ秒単位で値を増やす手順を繰り返します。方法4
ファイアウォールを無効にします。
ライセンスサーバーとクライアント PC の双方に対して行ってください。
※ファイアウォールの設定を変更後は、サーバー PC の再起動、または、[最新の情報に更新] を行ってください。
方法5
サーバー PC(ホスト PC)の [27000] ポートの解放と service.txt の記述の変更
- サーバー PC(ホスト PC)の以下の場所の service.txt を開きます。
ArcGIS 10.0 の場合
C:\Program Files\ArcGIS\License10.0\bin\service.txt
ArcGIS 10.1, 10.2, 10.2.x, 10.3, 10.3.1, 10.4, 10.4.1, 10.5, 10.5.1 の場合
C:\Program Files\ArcGIS\License10.1\bin\service.txt
C:\Program Files\ArcGIS\License10.2\bin\service.txt
C:\Program Files\ArcGIS\License10.3\bin\service.txt
C:\Program Files\ArcGIS\License10.4\bin\service.txt
C:\Program Files\ArcGIS\License10.5\bin\service.txt
ArcGIS License Manager 2018.0 ~ 2020.1 の場合
C:\Program Files (x86)\ArcGIS\LicenseManager\bin\service.txt
License Manager 2021.0 以降の場合
C:\Program Files\ArcGIS\LicenseManager\bin\service.txt
service.txt を「メモ帳」等のプログラムで開くと以下のように表示されています。SERVER this_host ANY
VENDOR ARCGIS -
以下のように記述 (修正) し、保存します(コピー&ペーストにて修正しないでください)。
SERVER this_host ANY 27000
VENDOR ARCGIS 27010
この記述の場合は、ファイアウォールのポートの設定が「無効」になっているか、または、「27000」と「27010」のポートが解放されている必要があります。 -
ライセンスサーバーを再起動します(再起動しませんとポートの変更やService.txt の変更が反映されません)。
-
クライアント側の PC にて、ArcGIS Administrator を起動し [利用可能ライセンス] フォルダのライセンスマネージャ欄に 「27000@ライセンスマネージャのPC名」 を入力します。
(例: 27000@licensesvr1)
補足
その他、ライセンスが返却できない原因としましては、ライセンスサーバーのシステムクロックとクライアント P Cのシステムクロックの時間が異なっていることがございます(数時間程度異なる場合は、ライセンスの返却ができません)。
ライセンスサーバーとクライアント PC のシステムクロックの時間に相違がないかをご確認ください。異なっている場合は、双方を一致させるようにしてください。上記すべてをお試しいただいても状況が改善されない (返却できない) 場合には、借用期限が切れる日までお待ちいただくか、お急ぎの場合には、弊社サポート窓口までお問い合わせください。
- お使いのライセンスサーバー PC においてコンピューター名とフルコンピューター名を確認します。
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