FAQ
Portal for ArcGIS に共有されたアイテムやグループが表示されなくなった
ナレッジ番号:5641 | 登録日:2023/10/17 | 更新日:2024/11/21
概要
Portal for ArcGIS に共有したアイテムやグループが [コンテンツ] ページやアイテムの検索画面で表示されない場合の対処方法を紹介します。
原因
Portal for ArcGIS は管理しているユーザー、グループ、アイテムの情報の表示にインデックスを使用しています。何らかの原因でこのインデックスが不正な状態となってしまった場合、サイト上でアイテムや検索結果の表示、新規に共有されたアイテムが [コンテンツ] ページに表示されない等の問題が発生します。
対処法
Portal Administrator Directory にログインし、インデックスの状態を確認 (Index Status) した上で、インデックスの再構築 (Reindex) を実行します。
なお、この方法は Portal for ArcGIS で以下のような操作を行った場合にも必要です。- 旧バージョンからのアップグレード
Portal for ArcGIS のアップグレード
アップグレード完了後、アイテムやユーザーの表示が正常でない場合に以下の手順を行ってください。
- ArcGIS Living Atlas コンテンツへのアクセス許可の無効化および有効化
ArcGIS Living Atlas コンテンツへの構成
ArcGIS Living Atlas コンテンツへのアクセス許可を変更された場合は、以下の手順を行ってください。
操作手順は以下のとおりです。
インデックスの状態を確認
- Portal Administrator Directory (https://<FQDN>:7443/arcgis/portaladmin) にアクセスし、[Login] より Portal for ArcGIS の管理権限を持ったユーザーでログインします。
- [System] → [Indexer] → [Index Status] をクリックします。
上記の操作を行った後、しばらくすると Portal for ArcGIS の使用しているインデックスの状態が表示されます。
実際のアイテムの数とインデックスの数が異なっている場合、表に赤字で表示されます。インデックスの再構築を行う場合は、この赤字となっている項目の [Type] を控えておきます。
インデックスの再構築
- Portal Administrator Directory (https://<FQDN>:7443/arcgis/portaladmin) にアクセスし、[Login] より Portal for ArcGIS の管理権限を持ったユーザーでログインします。
- [System] → [Indexer] → [Reindex] をクリックします。
- [Mode] を「インデックスの確認」の操作で確認した [Type] に設定します。
※ Portal for ArcGIS をアップグレードした場合は [Full] を設定します。
※ ArcGIS Living Atlas コンテンツへのアクセス許可を変更した場合は [Search] を設定します。 - [Reindex] をクリックし、インデックスの再構築を実行します。
- インデックスの再構築が開始された旨のメッセージが表示されます。
「You can monitor the status by refreshing the Status page.」に記載されている [Status] のリンクをクリックします。
※ インデックス再構築の処理が行われている場合はその旨が表示されます。しばらくしてからページを更新し、インデックスのステータスを確認してください。
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インデックスの状態が表示され、実際のアイテム数とインデックスの数が合っていることを確認します。
- 旧バージョンからのアップグレード
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