FAQ
ArcMap 版 Business Analyst Desktop のバージョンアップ後にマップ ドキュメント内のデータへのリンクが切れる
ナレッジ番号:2961 | 登録日:2023/05/29 | 更新日:2024/11/21
概要
Business Analyst のバージョンアップを行うと、バージョンアップ前に保存したマップ ドキュメント (*.mxd) を開いた際に、店舗や商圏等の解析結果や、背景地図・統計レイヤー (Business Analyst データ レイヤー) などのリンクが切れてしまい、マップに表示されなくなる。
原因
2つの原因が考えられますが、いずれもデータのパスが変更されたことが原因です。
- Business Analyst Desktop のバージョンアップ時に、Business Analyst の作業フォルダー (通常、C:\My Output Data) がバックアップされ、フォルダーの名称が変更されたため。
- 背景地図・統計レイヤーの新しいデータへのパスが指定されていないため。
解決策
それぞれ以下の方法で解決することができます。
方法① Business Analyst の作業フォルダーのバックアップ フォルダーの名称を変更する
Business Analyst Desktop のバージョンアップを行うと、Business Analyst の解析結果が保存される作業フォルダー (通常、C:\My Output Data) のバックアップが作成されます。このバックアップ フォルダーを再利用することで、データのリンク切れを解消できます。詳しくは、FAQ「ArcMap 版 Business Analyst Desktop をバージョンアップしても、プロジェクト内のデータは使用できますか?」をご覧ください。方法② [Business Analyst] ツールバーを利用して、背景地図・統計レイヤーを再度追加する
以下の手順で、背景地図・統計レイヤーを更新することができます。
- 更新したいマップ ドキュメント (*.mxd) を開きます。
- [Business Analyst] ツールバー → [マップ] メニューを開き、チェックの入っている項目を選択してチェックを外し、[コンテンツ] ウィンドウから一度レイヤーを削除します。
- 再び [マップ] メニューを開き、[Business Analyst データ レイヤー] と、表示させたい背景地図の順で再びチェックを入れます。
- 統計レイヤーと背景地図が正常に追加されたことを確認して、マップ ドキュメントを上書き保存します。
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