FAQ
ディゾルブ、ユニオン、インターセクト等を行うとフィーチャの形状が変わったり、空の出力が生成される

ナレッジ番号:1567 | 登録日:2023/05/29 | 更新日:2024/03/19

現象

ディゾルブ等を実行後、フィーチャの形状が、元のフィーチャと異なったり、フィーチャ自体がなくなってしまうことがあります。

原因

ArcGIS Desktop 9.2 以降のバージョンでは、ディゾルブ等のデータの処理を行う場合、座標精度という概念が適用され、座標系によってデータの精度が決定されます。
※ 座標値を高精度の空間参照で格納する機能は、ArcGIS 9.2 の新しい機能です。

座標系の定義がない場合でもこの座標精度が考慮され、処理結果が元のフィーチャの形状と異なることがあります。

また、データ(ジオメトリ)が破損している場合も、フィーチャの形状が変更されたり、フィーチャ自体が消滅することがあります。

回避策1

フィーチャの形状が異なる原因として、データに投影法の定義がされていないこととがあります。ディゾルブ等を行うデータに投影法の定義がされていない場合は、ArcToolbox のツールで座標系の定義します。

ArcToolbox → [データ管理ツール] → [投影変換と座標変換] → [投影法の定義] にて座標系を定義します。

回避策2

データが破損しているため、ディゾルブ等の処理によりフィーチャがなくなってしまうことがあります。そのような場合は、データに対して[ジオメトリのチェック] ツールを実行します。[ジオメトリのチェック] ツールを実行し、問題が発見されると出力されたテーブルにフィールドにフィーチャの ID と問題の内容が記載されます。
問題が発見された場合は、[ジオメトリの修正] ツールを実行します(但し、[ジオメトリの実行] ツールを実行することで本来なら存在できないような微小ポリゴンが消滅することがあります。)

[ジオメトリのチェック] ツール

ArcToolbox → [データ管理ツール] → [フィーチャ] → [ジオメトリのチェック]

「ジオメトリのチェック」ツールを実行後、テーブルが出力されます。このテーブルを開いていただき、中身が空の場合は問題がありませんが、問題がある場合は、問題のあるフィーチャに関する記述があります。その場合は、お手数ですが、以下の「ジオメトリの修正」をお試しください。

[ジオメトリの修正] ツール

ArcToolbox → [データ管理ツール] → [フィーチャ] → [ジオメトリの修正」

「ジオメトリの修正」ツールは、データを上書きしますので、「ジオメトリの修正」ツールの実行前には、必ずデータのバックアップをご用意ください。

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